1
Vote

Problem with Installation in WSS Portuguese - 2070

description

HI
 
I am "Install Copy List Item to a Secured List".
It will appear on action lits from Sharepoint Designer (imagem attached), but after the selecting "Install Copy List Item to a Secured List" nothing will come out on windows.
I have done the following steps :
 
have added in the file "C:\Programas\Ficheiros comuns\Microsoft Shared\web server extensions\12\TEMPLATE\2070\Workflow\WSS.ACTIONS" the following statemante:
 
<Action Name="Copy List Item to Secured List"
        ClassName="CopyListItemToSecuredList.Activity1" 
        Assembly="CopyListItemToSecuredList, Version=1.2.0.0, Culture=neutral, PublicKeyToken=a8999d7c6c56e591" 
        AppliesTo="all" 
        Category="Custom Actions">
  <RuleDesigner Sentence="Copy list item from %1 to secured list %2.">
    <FieldBind Field="ListID,ListItem" Text="this list" Id="1" DesignerType="ChooseListItem" />
    <FieldBind Field="ToListId" Text="this list" Id="2" DesignerType="ListNames" />
  </RuleDesigner>
  <Parameters>
    <Parameter Name="ListID" Type="System.String, mscorlib" Direction="In" />
    <Parameter Name="ListItem" Type="System.Int32, mscorlib" Direction="In" />
    <Parameter Name="ToListId" Type="System.String, mscorlib" Direction="In" />
    <Parameter Name="__Context" Type="Microsoft.SharePoint.WorkflowActions.WorkflowContext, Microsoft.SharePoint.WorkflowActions" Direction="In" />
  </Parameters>
</Action>
 
 
and in the web.config
 
 
<System.Workflow.ComponentModel.WorkflowCompiler>
<authorizedTypes>
  <authorizedType Assembly="System.Workflow.Activities, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="System.Workflow.*" TypeName="*" Authorized="True" />
  <authorizedType Assembly="System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="System.Workflow.*" TypeName="*" Authorized="True" />
  <authorizedType Assembly="System.Workflow.Runtime, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Namespace="System.Workflow.*" TypeName="*" Authorized="True" />
  <authorizedType Assembly="System.Transactions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System*" TypeName="*" Authorized="True" />
  <authorizedType Assembly="mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System*" TypeName="*" Authorized="True" />
  <authorizedType Assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System*" TypeName="*" Authorized="True" />
  <authorizedType Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint.Workflow" TypeName="SPWorkflowActivationProperties" Authorized="True" />
  <authorizedType Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint.Workflow" TypeName="SPWorkflowTaskProperties" Authorized="True" />
  <authorizedType Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint.Workflow" TypeName="SPWorkflowHistoryEventType" Authorized="True" />
  <authorizedType Assembly="Microsoft.SharePoint.WorkflowActions, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint.WorkflowActions" TypeName="*" Authorized="True" />
<authorizedType Assembly="CopyListItemToSecuredList, Version=1.20.0, Culture=neutral, PublicKeyToken=a8999d7c6c56e591" Namespace="CopyListItemToSecuredList" TypeName="*" Authorized="True" />
 
</authorizedTypes>
 
</System.Workflow.ComponentModel.WorkflowCompiler>
 
Any sugestion how to work it around ?
 
Best regards

file attachments

comments

carnut2408 wrote Dec 2, 2008 at 10:35 PM

Everything looks correct in the setup. I have come across a bit of advice since I created this that says you should never modify the wss.actions file. Instead create another .actions file and put it in the same folder. It worked when I tried it. You do have to restart IIS for it to be found.
Here is the explanation mosschampions.com/blogs/moss/archive/2006/12/14/How-to-not-modify-WSS.Actions-.aspx

wrote Feb 2, 2013 at 4:31 AM